Monday, March 21, 2011

[SOLVED]Requires installation of untrusted packages "The action would require the installation of packages from not authenticated sources."

Requires installation of untrusted packages
"The action would require the installation of packages from not authenticated sources."

These words made me tensed for three more days because this message is often appeared in your software center or with your synaptic. I thought I have too reintall the os to resolve this. but this problem can be solved by  executing a single line command in shell.

go to applications->accesories->terminal


and type the following line and press enter to solve this problem.

 sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 40976EAF437D05B5

this will replace the broken keys of your authentication part and opens some repositories for getting software


6 comments:

  1. I've had some kind of trouble with updating since late in the use of 11.10 and hoped it would be resolved with the upgrade to 12.04. It has continued to be patchy. Finally this week, it just stopped completely with the error above.

    I tried your suggestion and it repaired the keys (which may have been the original problem), but the update still produced the same error.

    I went into recovery mode and tried dpkg to repair broken packages. It failed because it had trouble connecting to the internet, but suggested:

    apt-get update --fix-missing

    I re-entered Ubuntu and ran that successfully in the terminal. Then I ran the update successfully.

    Thank-you for your assistance and hope, because I was very close to a re-install!

    ReplyDelete
    Replies
    1. Hi Andrew,

      Happy to know that your issue got solved. Thanks for sharing your experience here. This may help people facing similiar issues.

      Delete
  2. gpg: requesting key 437D05B5 from hkp server keyserver.ubuntu.com
    gpgkeys: HTTP fetch error 6: Couldn't resolve host 'keyserver.ubuntu.com'
    gpg: no valid OpenPGP data found.
    gpg: Total number processed: 0

    ReplyDelete
  3. Hi, I've ran the comand "apt-get update --fix-missing" But still I'm messing around some were.. Please take a look the error I'm getting in terminal while update te apt-get

    "Get:4 http://ppa.launchpad.net trusty InRelease
    100% [4 InRelease gpgv 45.1 kB]Splitting up /var/lib/apt/lists/partial/ppa.launchpad.net_fixnix_netspeed_ubuntu_distsIgn http://ppa.launchpad.net trusty InReleaseled
    E: GPG error: http://ppa.launchpad.net trusty InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)"

    Thanks in Advance !!

    ReplyDelete
  4. Also If I "apt-get update" throws the following error..

    "Hit http://ppa.launchpad.net trusty/main Translation-en
    100% [1 InRelease gpgv 45.0 kB] [Waiting for headers]Splitting up /var/lib/apt/lists/partial/ppa.launchpad.net_fixnixIgn http://ppa.launchpad.net trusty InRelease signature failed
    E: GPG error: http://ppa.launchpad.net trusty InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)"

    ReplyDelete